|
|
| (14 dazwischenliegende Versionen desselben Benutzers werden nicht angezeigt) |
| Zeile 1: |
Zeile 1: |
| =Warum=
| | *[[IPv6 Vorteile]] |
| *Verknappung des IPv4 Adressraums.
| | *[[IPv6 Adresstypen]] |
| *Vergabe der restlichen IPv4 Blöcke nur noch gesonderte Vergabebedingungend.
| | *[[Adressnotation]] |
| =Vorteile von IPv6=
| | *[[Aufteilung des IPv6-Adressraums]] |
| *längere Adressen und dadurch ein größerer Adressraum
| | *[[IPv6 Besondere Adressen]] |
| *mehrere IPv6-Adressen pro Host mit unterschiedlichen Gültigkeitsbereichen
| | *[[Multicast Adressen]] |
| *Autokonfiguration der IPv6-Adressen möglich | | *[[IPv6 Funktionalität]] |
| *Multicast durch spezielle Adressen
| |
| *schnelleres Routing
| |
| *Punkt-zu-Punkt-Verschlüsselung mit IPsec
| |
| *Quality of Service
| |
| *Datenpakete bis 4 GByte (Jumbograms)
| |
| | |
| =Aufbau=
| |
| ==Adresstypen==
| |
| Es gibt drei IP-Adresstypen:
| |
| *Unicast
| |
| Senden an einen bestimmten Empfänger im Internet (normale Adressierung).
| |
| | |
| [[Datei:ipv6-1.png]] | |
| | |
| *Multicast | |
| Senden an einige Geräte im selben Netz oder Geräte im Netz.
| |
| | |
| [[Datei:ipv6-2.png]] | |
| *Anycast | |
| | |
| Hierbei ist mehreren Endpunkten die gleiche Adresse zugewiesen. Bei einer Anfrage wird die Anfrage immer zu dem topologisch am nächsten liegenden Endpunkt geroutet.
| |
| | |
| [[Datei:ipv6-3.png]] | |
| | |
| *Broadcast | |
| Wird von Multicast übernommen.
| |
| | |
| [[Datei:ipv6-4.png]] | |
| | |
| Verwendete Grafiken: Creative Commons CC0 1.0 Universal (CC0 1.0) Public Domain Dedication
| |
| | |
| =Adressnotation=
| |
| Die Adressen sind 128 Bit lang
| |
| ==Vollständige Schreibweise==
| |
| 2001:0DB2:7280:97e8:6c18:0000:a53f:0001
| |
| ==Führende Nullen werden weggelassen==
| |
| 2001:DB2:7280:97e8:6c18:0:a53f:1
| |
| | |
| ==Lange Sequenzen aus 000 werden durch :: ersetzt==
| |
| 2001:DB2:0000:0000:7280:97e8:6c18:0001
| |
| | |
| 2001:DB2::7280:97e8:6c18:1
| |
| ==Bei mehreren Nullreihen werden nur die Links durch :: ersetzt==
| |
| 2001:DB2:0000:0000:7280:0000:0000:1
| |
| | |
| 2001:DB2::7280:0:0:1
| |
| | |
| =Aufteilung des IPv6-Adressraums=
| |
| Hat z. B. ein Netzwerkgerät die IPv6-Adresse
| |
| : <code style="border:0; padding:0;"><span style="background: #FFC0A0; padding: 1.5ex 0; line-height: 3em;"><span style="background: #A0C0FF; padding: 1ex 0;"><span style="background: #A0FFA0; padding: .5ex 0;"><span style="background:#FFA0A0">2001:db8:</span>85a3:</span>8</span>d3:</span><span style="background:#FFFFA0">1319:8a2e:370:7347</span><span style="background:#FFC0A0">/64</span></code>,
| |
| so lautet das Präfix
| |
| : <span style="background:#FFC0A0; font-family:monospace,monospace;">2001:db8:85a3:8d3::/64</span>
| |
| und der Interface-Identifier
| |
| : <span style="background: #FFFFA0; font-family: monospace,monospace; margin-left: 166px;">1319:8a2e:370:7347</span>.
| |
| Der Provider bekam von der [[Regional Internet Registry|RIR]] wahrscheinlich das Netz
| |
| : <span style="background:#FFA0A0; font-family:monospace,monospace;">2001:db8::/32</span>
| |
| zugewiesen und der Endkunde vom Provider möglicherweise das Netz
| |
| : <span style="background:#A0FFA0; font-family:monospace,monospace;">2001:db8:85a3::/48</span>,
| |
| oder aber nur
| |
| : <span style="background:#A0C0FF; font-family:monospace,monospace;">2001:db8:85a3:800::/56</span>.
| |
| | |
| =Besondere Adressen=
| |
| * ::/128 | |
| Nicht spezifizierte Adresse. Sie zeigt das Fehlen einer Adresse an. Sie wird beispielsweise von einem initialisierenden Host als Absenderadresse in IPv6-Paketen verwendet, solange er seine eigene Adresse noch nicht mitgeteilt bekommen hat.
| |
| * ::/0
| |
| Die Default Route, die verwendet wird, wenn in der Routingtabelle kein Eintrag gefunden wird. Dies entspricht 0.0.0.0/0 unter IPv4.
| |
| * ::1/128
| |
| Ist die Adresse des eigenen Standortes (loopback-Adresse).
| |
| *fe80::/10 -- fe80:: - febf::
| |
| Alle Adressen in diesem Bereich werden nicht vom Router weitergeleitet, sind somit nur im LAN erreichbar. Link Local Unicast Adressen dienen hauptsächlich der Autokonfiguration.
| |
| *fc00::/7 -- fc00:: - fdff:: | |
| Privater Adressbereich, also innerhalb eines LANs. Bei IPv4 liegen die Bereiche für diesen Zweck bei 10.0.0.0/8, 172.16.0.0/12 und 192.168.0.0/16.
| |
| Default Gateway
| |
| * fe80::1
| |
| | |
| =Multicast Adressen=
| |
| *ff00::/8 | |
| (ff…) stehen für Multicast-Adressen.
| |
| | |
| Nach dem Multicast-Präfix folgen 4 Bits für Flags und 4 Bits für den Gültigkeitsbereich (Scope). Für die Flags sind zurzeit folgende Kombinationen gültig.
| |
| | |
| *0: Permanent definierte wohlbekannte Multicast-Adressen (von der IANA zugewiesen)[30]
| |
| *1: (T-Bit gesetzt) Transient (vorübergehend) oder dynamisch zugewiesene Multicast-Adressen
| |
| *3: (P-Bit gesetzt, erzwingt das T-Bit) Unicast-Prefix-based Multicast-Adressen (RFC 3306)
| |
| *7: (R-Bit gesetzt, erzwingt P- und T-Bit) Multicast-Adressen, welche die Adresse des Rendezvous-Points enthalten (RFC 3956)
| |
| ==Die folgenden Gültigkeitsbereiche sind definiert==
| |
| | |
| *1: interfacelokal, diese Pakete verlassen die Schnittstelle nie. (Loopback)
| |
| *2: link-lokal, werden von Routern grundsätzlich nie weitergeleitet und können deshalb das Subnetz nicht verlassen.
| |
| *4: adminlokal, der kleinste Bereich, dessen Abgrenzung in den Routern speziell administriert werden muss.
| |
| *5: sitelokal, dürfen zwar geroutet werden, jedoch nicht von Border-Routern.
| |
| *8: organisationslokal, die Pakete dürfen auch von Border-Routern weitergeleitet werden, bleiben jedoch „im Unternehmen“ (hierzu müssen seitens des Routing-Protokolls entsprechende Vorkehrungen getroffen werden).
| |
| *e: globaler Multicast, der überallhin geroutet werden darf.
| |
| *0, 3, f: reservierte Bereiche
| |
| Die restlichen Bereiche sind nicht zugewiesen und dürfen von Administratoren benutzt werden, um weitere Multicast-Regionen zu definieren.
| |
| ==Beispiele für wohlbekannte Multicast-Adressen==
| |
| *ff01::1, ff02::1: All Nodes Adressen. Entspricht dem Broadcast.
| |
| *ff01::2, ff02::2, ff05::2: All Routers Adressen, adressiert alle Router in einem Bereich.
| |
| | |
| =Funktionalität=
| |
| =Autokonfiguration=
| |
| Mittels Stateless Address Autoconfiguration (SLAAC - RFC 4862) kann ein Host vollautomatisch eine funktionsfähige Internetverbindung aufbauen. Dazu kommuniziert er mit den für sein Netzwerksegment zuständigen Routern, um die notwendige Konfiguration zu ermitteln.
| |
| | |
| ==Ablauf==
| |
| Zur initialen Kommunikation mit dem Router weist sich der Host eine link-lokale Adresse zu, die im Falle einer Ethernet-Schnittstelle etwa aus deren Hardware-Adresse berechnet werden kann. Damit kann ein Gerät sich mittels des Neighbor Discovery Protocols (NDP, siehe auch ICMPv6-Funktionalität) auf die Suche nach den Routern in seinem Netzwerksegment machen. Dies geschieht durch eine Anfrage an die Multicast-Adresse ff02::2, über die alle Router eines Segments erreichbar sind (Router Solicitation).
| |
| | |
| Ein Router versendet auf eine solche Anfrage hin Information zu verfügbaren Präfixen, also Information über die Adressbereiche, aus denen ein Gerät sich selbst Unicast-Adressen zuweisen darf. Die Pakete, die diese Informationen tragen, werden Router Advertisements genannt. Sie besitzen ICMPv6-Typ 134 (0x86) und besitzen Informationen über die Lifetime, die MTU und das Präfix des Netzwerks. An ein solches Präfix hängt der Host den auch für die link-lokale Adresse verwendeten Interface-Identifier an.
| |
| | |
| Um die doppelte Vergabe einer Adresse zu verhindern, ist der Mechanismus Duplicate Address Detection (DAD – Erkennung doppelt vergebener Adressen) vorgesehen. Ein Gerät darf bei der Autokonfiguration nur unvergebene Adressen auswählen. Der DAD-Vorgang läuft ebenfalls ohne Benutzereingriff via NDP ab.
| |
| | |
| =Quellen= | | =Quellen= |
| *https://kompendium.infotip.de/ipv6.html | | *https://kompendium.infotip.de/ipv6.html |
| Zeile 121: |
Zeile 11: |
| *https://de.wikipedia.org/wiki/IPv6 | | *https://de.wikipedia.org/wiki/IPv6 |
| *https://voiceoverit.de/netzwerk/broadcast-multicast-unicast-anycast/121/ | | *https://voiceoverit.de/netzwerk/broadcast-multicast-unicast-anycast/121/ |
| | [[Kategorie:IPv6]] |